Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
7502d4bd
Commit
7502d4bd
authored
16 years ago
by
Felix Fietkau
Browse files
Options
Downloads
Patches
Plain Diff
add support for build-only packages which do not appear in menuconfig
SVN-Revision: 14009
parent
9b669173
No related branches found
No related tags found
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
include/package-defaults.mk
+1
-0
1 addition, 0 deletions
include/package-defaults.mk
include/package-dumpinfo.mk
+1
-0
1 addition, 0 deletions
include/package-dumpinfo.mk
scripts/metadata.pl
+3
-0
3 additions, 0 deletions
scripts/metadata.pl
scripts/metadata.pm
+1
-0
1 addition, 0 deletions
scripts/metadata.pm
with
6 additions
and
0 deletions
include/package-defaults.mk
+
1
−
0
View file @
7502d4bd
...
@@ -31,6 +31,7 @@ define Package/Default
...
@@ -31,6 +31,7 @@ define Package/Default
SUBMENUDEP
:=
SUBMENUDEP
:=
TITLE
:=
TITLE
:=
KCONFIG
:=
KCONFIG
:=
BUILDONLY
:=
endef
endef
Build/Patch
:
=$(Build/Patch/Default)
Build/Patch
:
=$(Build/Patch/Default)
...
...
This diff is collapsed.
Click to expand it.
include/package-dumpinfo.mk
+
1
−
0
View file @
7502d4bd
...
@@ -30,6 +30,7 @@ ifneq ($(DUMP),)
...
@@ -30,6 +30,7 @@ ifneq ($(DUMP),)
echo
"Maintainer:
$(
MAINTAINER
)
"
;
\
echo
"Maintainer:
$(
MAINTAINER
)
"
;
\
echo
"Type:
$(
if
$(
Package/
$(
1
)
/targets
)
,
$(
Package/
$(
1
)
/targets
)
,
$(
if
$(
PKG_TARGETS
)
,
$(
PKG_TARGETS
)
,ipkg
))
"
;
\
echo
"Type:
$(
if
$(
Package/
$(
1
)
/targets
)
,
$(
Package/
$(
1
)
/targets
)
,
$(
if
$(
PKG_TARGETS
)
,
$(
PKG_TARGETS
)
,ipkg
))
"
;
\
$(
if
$(
KCONFIG
)
,echo
"Kernel-Config:
$(
KCONFIG
)
"
;)
\
$(
if
$(
KCONFIG
)
,echo
"Kernel-Config:
$(
KCONFIG
)
"
;)
\
$(
if
$(
BUILDONLY
)
,echo
"Build-Only:
$(
BUILDONLY
)
"
;)
\
echo
-n
"Description: "
;
\
echo
-n
"Description: "
;
\
getvar
$(
call shvar,Package/
$(
1
)
/description
);
\
getvar
$(
call shvar,Package/
$(
1
)
/description
);
\
$(
if
$(
URL
)
,echo
;
echo
"
$(
URL
)
"
;)
\
$(
if
$(
URL
)
,echo
;
echo
"
$(
URL
)
"
;)
\
...
...
This diff is collapsed.
Click to expand it.
scripts/metadata.pl
+
3
−
0
View file @
7502d4bd
...
@@ -398,6 +398,7 @@ sub mconf_depends {
...
@@ -398,6 +398,7 @@ sub mconf_depends {
$depend
=
$
2
;
$depend
=
$
2
;
}
}
next
if
$seen
->
{
$depend
};
next
if
$seen
->
{
$depend
};
next
if
$package
{
$depend
}
and
$package
{
$depend
}
->
{
buildonly
};
$seen
->
{
$depend
}
=
1
;
$seen
->
{
$depend
}
=
1
;
if
(
$vdep
=
$package
{
$depend
}
->
{
vdepends
})
{
if
(
$vdep
=
$package
{
$depend
}
->
{
vdepends
})
{
$depend
=
join
("
||
",
map
{
"
PACKAGE_
"
.
$_
}
@$vdep
);
$depend
=
join
("
||
",
map
{
"
PACKAGE_
"
.
$_
}
@$vdep
);
...
@@ -442,6 +443,7 @@ sub print_package_config_category($) {
...
@@ -442,6 +443,7 @@ sub print_package_config_category($) {
foreach
my
$spkg
(
sort
{
uc
(
$a
)
cmp
uc
(
$b
)}
keys
%spkg
)
{
foreach
my
$spkg
(
sort
{
uc
(
$a
)
cmp
uc
(
$b
)}
keys
%spkg
)
{
foreach
my
$pkg
(
@
{
$spkg
{
$spkg
}})
{
foreach
my
$pkg
(
@
{
$spkg
{
$spkg
}})
{
next
if
$pkg
->
{
buildonly
};
my
$menu
=
$pkg
->
{
submenu
};
my
$menu
=
$pkg
->
{
submenu
};
if
(
$menu
)
{
if
(
$menu
)
{
$menu_dep
{
$menu
}
or
$menu_dep
{
$menu
}
=
$pkg
->
{
submenudep
};
$menu_dep
{
$menu
}
or
$menu_dep
{
$menu
}
=
$pkg
->
{
submenudep
};
...
@@ -543,6 +545,7 @@ sub gen_package_mk() {
...
@@ -543,6 +545,7 @@ sub gen_package_mk() {
$config
=
"
\$
(CONFIG_PACKAGE_
$name
)
"
$config
=
"
\$
(CONFIG_PACKAGE_
$name
)
"
}
}
if
(
$config
)
{
if
(
$config
)
{
$pkg
->
{
buildonly
}
and
$config
=
"";
print
"
package-
$config
+=
$pkg
->{subdir}
$pkg
->{src}
\n
";
print
"
package-
$config
+=
$pkg
->{subdir}
$pkg
->{src}
\n
";
$pkg
->
{
prereq
}
and
print
"
prereq-
$config
+=
$pkg
->{subdir}
$pkg
->{src}
\n
";
$pkg
->
{
prereq
}
and
print
"
prereq-
$config
+=
$pkg
->{subdir}
$pkg
->{src}
\n
";
}
}
...
...
This diff is collapsed.
Click to expand it.
scripts/metadata.pm
+
1
−
0
View file @
7502d4bd
...
@@ -88,6 +88,7 @@ sub parse_package_metadata($) {
...
@@ -88,6 +88,7 @@ sub parse_package_metadata($) {
}
}
};
};
/^Depends: \s*(.+)\s*$/
and
$pkg
->
{
depends
}
=
[
split
/\s+/
,
$
1
];
/^Depends: \s*(.+)\s*$/
and
$pkg
->
{
depends
}
=
[
split
/\s+/
,
$
1
];
/^Build-Only: \s*(.+)\s*$/
and
$pkg
->
{
buildonly
}
=
1
;
/^Build-Depends: \s*(.+)\s*$/
and
$pkg
->
{
builddepends
}
=
[
split
/\s+/
,
$
1
];
/^Build-Depends: \s*(.+)\s*$/
and
$pkg
->
{
builddepends
}
=
[
split
/\s+/
,
$
1
];
/^Category: \s*(.+)\s*$/
and
do
{
/^Category: \s*(.+)\s*$/
and
do
{
$pkg
->
{
category
}
=
$
1
;
$pkg
->
{
category
}
=
$
1
;
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment