Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
7ed7784f
Commit
7ed7784f
authored
14 years ago
by
Michael Büsch
Browse files
Options
Downloads
Patches
Plain Diff
Support parallel build of certain packages
SVN-Revision: 22696
parent
4bd5e0e6
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
Config.in
+32
-0
32 additions, 0 deletions
Config.in
include/package-defaults.mk
+1
-1
1 addition, 1 deletion
include/package-defaults.mk
include/package.mk
+2
-0
2 additions, 0 deletions
include/package.mk
with
35 additions
and
1 deletion
Config.in
+
32
−
0
View file @
7ed7784f
...
...
@@ -215,6 +215,38 @@ menu "Global build settings"
help
Enable IPV6 support in packages (passes --enable-ipv6 to configure scripts).
config PKG_BUILD_PARALLEL
bool
prompt "Compile certain packages parallelized"
default n
help
This adds a -jX option to certain packages that are known to
behave well for parallel build.
Note that this may overcommit CPU resources depending on the
-j level of the main make process, the number of package
submake jobs selected below and the number of actual CPUs present.
Example: If the main make is passed a -j4 and the submake -j
is also set to 4, we may end up with 16 parallel make processes
in the worst case.
You get maximum build performance, if you set the package build
jobs to the number of CPUs (cores) available and also start the main
make process with -jX, where X is the number of CPUs (cores).
However, make sure you have enough RAM available for
NR_CPUS to the power of two (NR_CPUS^2) make jobs.
If you are unsure, select N.
config PKG_BUILD_JOBS
int
prompt "Number of package submake jobs (2-512)"
range 2 512
default 2
depends on PKG_BUILD_PARALLEL
help
The number of jobs (-jX) to pass to packages submake.
comment "Stripping options"
choice
...
...
This diff is collapsed.
Click to expand it.
include/package-defaults.mk
+
1
−
1
View file @
7ed7784f
...
...
@@ -113,7 +113,7 @@ MAKE_PATH = .
define
Build/Compile/Default
$(MAKE_VARS)
\
$(MAKE)
-C
$(PKG_BUILD_DIR)/$(MAKE_PATH)
\
$(MAKE)
$(PKG_JOBS)
-C
$(PKG_BUILD_DIR)/$(MAKE_PATH)
\
$(MAKE_FLAGS)
\
$(1);
endef
...
...
This diff is collapsed.
Click to expand it.
include/package.mk
+
2
−
0
View file @
7ed7784f
...
...
@@ -10,6 +10,8 @@ all: $(if $(DUMP),dumpinfo,compile)
PKG_BUILD_DIR
?=
$(
BUILD_DIR
)
/
$(
PKG_NAME
)$(
if
$(
PKG_VERSION
)
,-
$(
PKG_VERSION
))
PKG_INSTALL_DIR
?=
$(
PKG_BUILD_DIR
)
/ipkg-install
PKG_MD5SUM
?=
unknown
PKG_BUILD_PARALLEL
?=
PKG_JOBS
?=
$(
if
$(
PKG_BUILD_PARALLEL
)
,
$(
if
$(
CONFIG_PKG_BUILD_PARALLEL
)
,-j
$(
CONFIG_PKG_BUILD_JOBS
)))
include
$(INCLUDE_DIR)/prereq.mk
include
$(INCLUDE_DIR)/host.mk
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment