Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
80d6e3b2
Commit
80d6e3b2
authored
15 years ago
by
Felix Fietkau
Browse files
Options
Downloads
Patches
Plain Diff
add an arch suffix for handling different variants of arm/mips for the toolchain/target directories
SVN-Revision: 20215
parent
411ab987
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
rules.mk
+21
-4
21 additions, 4 deletions
rules.mk
with
21 additions
and
4 deletions
rules.mk
+
21
−
4
View file @
80d6e3b2
...
@@ -44,6 +44,23 @@ else
...
@@ -44,6 +44,23 @@ else
FPIC
:=
-fpic
FPIC
:=
-fpic
endif
endif
ARCH_SUFFIX
:=
ifneq
($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX
:=
_r2
endif
ifneq
($(findstring -march=armv4,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX
:=
_v4
endif
ifneq
($(findstring -march=armv4t,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX
:=
_v4t
endif
ifneq
($(findstring -march=armv5t,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX
:=
_v5t
endif
ifneq
($(findstring -march=armv5te,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX
:=
_v5te
endif
DL_DIR
:=
$(
if
$(
call qstrip,
$(
CONFIG_DOWNLOAD_FOLDER
))
,
$(
call qstrip,
$(
CONFIG_DOWNLOAD_FOLDER
))
,
$(
TOPDIR
)
/dl
)
DL_DIR
:=
$(
if
$(
call qstrip,
$(
CONFIG_DOWNLOAD_FOLDER
))
,
$(
call qstrip,
$(
CONFIG_DOWNLOAD_FOLDER
))
,
$(
TOPDIR
)
/dl
)
BIN_DIR
:=
$(
TOPDIR
)
/bin/
$(
BOARD
)
BIN_DIR
:=
$(
TOPDIR
)
/bin/
$(
BOARD
)
INCLUDE_DIR
:=
$(
TOPDIR
)
/include
INCLUDE_DIR
:=
$(
TOPDIR
)
/include
...
@@ -58,10 +75,10 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
...
@@ -58,10 +75,10 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
REAL_GNU_TARGET_NAME
=
$(
OPTIMIZE_FOR_CPU
)
-openwrt-linux
$(
if
$(
TARGET_SUFFIX
)
,-
$(
TARGET_SUFFIX
))
REAL_GNU_TARGET_NAME
=
$(
OPTIMIZE_FOR_CPU
)
-openwrt-linux
$(
if
$(
TARGET_SUFFIX
)
,-
$(
TARGET_SUFFIX
))
GNU_TARGET_NAME
=
$(
OPTIMIZE_FOR_CPU
)
-openwrt-linux
GNU_TARGET_NAME
=
$(
OPTIMIZE_FOR_CPU
)
-openwrt-linux
DIR_SUFFIX
:=
_
$(
LIBC
)
-
$(
LIBCV
)$(
if
$(
CONFIG_EABI_SUPPORT
)
,_eabi
)
DIR_SUFFIX
:=
_
$(
LIBC
)
-
$(
LIBCV
)$(
if
$(
CONFIG_EABI_SUPPORT
)
,_eabi
)
BUILD_DIR
:=
$(
BUILD_DIR_BASE
)
/target-
$(
ARCH
)$(
DIR_SUFFIX
)$(
if
$(
BUILD_SUFFIX
)
,_
$(
BUILD_SUFFIX
))
BUILD_DIR
:=
$(
BUILD_DIR_BASE
)
/target-
$(
ARCH
)$(
ARCH_SUFFIX
)$(
DIR_SUFFIX
)$(
if
$(
BUILD_SUFFIX
)
,_
$(
BUILD_SUFFIX
))
STAGING_DIR
:=
$(
TOPDIR
)
/staging_dir/target-
$(
ARCH
)$(
DIR_SUFFIX
)
STAGING_DIR
:=
$(
TOPDIR
)
/staging_dir/target-
$(
ARCH
)$(
ARCH_SUFFIX
)$(
DIR_SUFFIX
)
BUILD_DIR_TOOLCHAIN
:=
$(
BUILD_DIR_BASE
)
/toolchain-
$(
ARCH
)
_gcc-
$(
GCCV
)$(
DIR_SUFFIX
)
BUILD_DIR_TOOLCHAIN
:=
$(
BUILD_DIR_BASE
)
/toolchain-
$(
ARCH
)
$(
ARCH_SUFFIX
)
_gcc-
$(
GCCV
)$(
DIR_SUFFIX
)
TOOLCHAIN_DIR
:=
$(
TOPDIR
)
/staging_dir/toolchain-
$(
ARCH
)
_gcc-
$(
GCCV
)$(
DIR_SUFFIX
)
TOOLCHAIN_DIR
:=
$(
TOPDIR
)
/staging_dir/toolchain-
$(
ARCH
)
$(
ARCH_SUFFIX
)
_gcc-
$(
GCCV
)$(
DIR_SUFFIX
)
PACKAGE_DIR
:=
$(
BIN_DIR
)
/packages
PACKAGE_DIR
:=
$(
BIN_DIR
)
/packages
else
else
ifeq
($(CONFIG_NATIVE_TOOLCHAIN),)
ifeq
($(CONFIG_NATIVE_TOOLCHAIN),)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment