Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
915e6b89
Commit
915e6b89
authored
17 years ago
by
Imre Kaloz
Browse files
Options
Downloads
Patches
Plain Diff
fixup softfloat handling
SVN-Revision: 10003
parent
80475bb5
No related branches found
No related tags found
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
rules.mk
+7
-0
7 additions, 0 deletions
rules.mk
toolchain/binutils/Makefile
+1
-0
1 addition, 0 deletions
toolchain/binutils/Makefile
toolchain/gcc/Makefile
+2
-0
2 additions, 0 deletions
toolchain/gcc/Makefile
toolchain/uClibc/Makefile
+1
-1
1 addition, 1 deletion
toolchain/uClibc/Makefile
with
11 additions
and
1 deletion
rules.mk
+
7
−
0
View file @
915e6b89
...
...
@@ -61,6 +61,13 @@ TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) -fhonour-copts
TARGET_CPPFLAGS
:=
-I
$(
STAGING_DIR
)
/usr/include -I
$(
STAGING_DIR
)
/include
TARGET_LDFLAGS
:=
-L
$(
STAGING_DIR
)
/usr/lib -L
$(
STAGING_DIR
)
/lib
ifeq
($(CONFIG_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION
:=
--with-float=soft
TARGET_CFLAGS
+=
-msoft-float
else
SOFT_FLOAT_CONFIG_OPTION
:=
endif
export
PATH
:=
$(
TARGET_PATH
)
export
STAGING_DIR
export
GCC_HONOUR_COPTS
:=
0
...
...
This diff is collapsed.
Click to expand it.
toolchain/binutils/Makefile
+
1
−
0
View file @
915e6b89
...
...
@@ -33,6 +33,7 @@ define Build/Configure
--target=
$(
REAL_GNU_TARGET_NAME
)
\
--disable-werror
\
--disable-nls
\
$(
SOFT_FLOAT_CONFIG_OPTION
)
\
$(
call qstrip,
$(
CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS
))
\
);
endef
...
...
This diff is collapsed.
Click to expand it.
toolchain/gcc/Makefile
+
2
−
0
View file @
915e6b89
...
...
@@ -60,6 +60,7 @@ define Stage1/Configure
--disable-nls
\
--disable-libmudflap
\
--disable-multilib
\
$(
SOFT_FLOAT_CONFIG_OPTION
)
\
$(
call qstrip,
$(
CONFIG_EXTRA_GCC_CONFIG_OPTIONS
))
\
)
;
endef
...
...
@@ -92,6 +93,7 @@ define Stage2/Configure
--disable-nls
\
--disable-libmudflap
\
--disable-multilib
\
$(
SOFT_FLOAT_CONFIG_OPTION
)
\
$(
call qstrip,
$(
CONFIG_EXTRA_GCC_CONFIG_OPTIONS
))
\
)
;
endef
...
...
This diff is collapsed.
Click to expand it.
toolchain/uClibc/Makefile
+
1
−
1
View file @
915e6b89
...
...
@@ -44,7 +44,7 @@ define Build/Prepare
$(
call
Build/Prepare/Default
)
$(CP)
config/$(ARCH)
$(
if
$(
wildcard config/
$(
ARCH
)
.
$(
BOARD
))
,
$(
BOARD
))
$(PKG_BUILD_DIR)/.config
$(SED)
's,^KERNEL_SOURCE=.*,KERNEL_SOURCE=\"$(LINUX_HEADERS_DIR)\",g'
\
-e
's,.*HAS_FPU.*,HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,
n
),g'
\
-e
's,.*HAS_FPU.*,HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,
y
),g'
\
-e
's,^.*UCLIBC_HAS_LFS.*,UCLIBC_HAS_LFS=$(if $(CONFIG_LARGEFILE),y,n),g'
\
-e
's,.*DO_C99_MATH.*,DO_C99_MATH=$(if $(CONFIG_C99_MATH),y,n),g'
\
$(PKG_BUILD_DIR)/.config
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment