Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
9622f685
Commit
9622f685
authored
12 years ago
by
Jo-Philipp Wich
Browse files
Options
Downloads
Patches
Plain Diff
buildroot: allow specifying libc personality for external toolchains
SVN-Revision: 35703
parent
330ae61b
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
scripts/ext-toolchain.sh
+4
-0
4 additions, 0 deletions
scripts/ext-toolchain.sh
toolchain/Config.in
+11
-0
11 additions, 0 deletions
toolchain/Config.in
toolchain/wrapper/Makefile
+1
-1
1 addition, 1 deletion
toolchain/wrapper/Makefile
with
16 additions
and
1 deletion
scripts/ext-toolchain.sh
+
4
−
0
View file @
9622f685
...
@@ -356,6 +356,10 @@ print_config() {
...
@@ -356,6 +356,10 @@ print_config() {
echo
"CONFIG_TOOLCHAIN_PREFIX=
\"
$prefix
\"
"
>>
"
$config
"
echo
"CONFIG_TOOLCHAIN_PREFIX=
\"
$prefix
\"
"
>>
"
$config
"
echo
"CONFIG_TARGET_NAME=
\"
$target
\"
"
>>
"
$config
"
echo
"CONFIG_TARGET_NAME=
\"
$target
\"
"
>>
"
$config
"
if
[
"
$LIBC_TYPE
"
!=
glibc
]
;
then
echo
"CONFIG_TOOLCHAIN_LIBC=
\"
$LIBC_TYPE
\"
"
>>
"
$config
"
fi
local
lib
local
lib
for
lib
in
C RT PTHREAD GCC STDCPP SSP GFORTRAN
;
do
for
lib
in
C RT PTHREAD GCC STDCPP SSP GFORTRAN
;
do
local
file
local
file
...
...
This diff is collapsed.
Click to expand it.
toolchain/Config.in
+
11
−
0
View file @
9622f685
...
@@ -50,6 +50,17 @@ menuconfig EXTERNAL_TOOLCHAIN
...
@@ -50,6 +50,17 @@ menuconfig EXTERNAL_TOOLCHAIN
default "/opt/cross/powerpc-unknown-linux-gnu" if powerpc
default "/opt/cross/powerpc-unknown-linux-gnu" if powerpc
default "/opt/cross/x86_64-unknown-linux-gnu" if x86_64
default "/opt/cross/x86_64-unknown-linux-gnu" if x86_64
config TOOLCHAIN_LIBC
string
prompt "Toolchain libc" if DEVEL
depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
default "uclibc"
help
Specify the libc type used by the external toolchain. The given value us passed as -m
flag to all gcc and g++ invocations. This is mainly intended for multilib toolchains
which support glibc and uclibc at the same time. If no value is specified, no -m flag
is passed.
config TOOLCHAIN_BIN_PATH
config TOOLCHAIN_BIN_PATH
string
string
prompt "Toolchain program path" if DEVEL
prompt "Toolchain program path" if DEVEL
...
...
This diff is collapsed.
Click to expand it.
toolchain/wrapper/Makefile
+
1
−
1
View file @
9622f685
...
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/toolchain-build.mk
...
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/toolchain-build.mk
define
toolchain_util
define
toolchain_util
$(
strip
$(
SCRIPT_DIR
)
/ext-toolchain.sh
--toolchain
$(
CONFIG_TOOLCHAIN_ROOT
)
\
$(
strip
$(
SCRIPT_DIR
)
/ext-toolchain.sh
--toolchain
$(
CONFIG_TOOLCHAIN_ROOT
)
\
--cflags
$(
CONFIG_TARGET_OPTIMIZATION
)
\
--cflags
$(
CONFIG_TARGET_OPTIMIZATION
)
\
--cflags
"
-muclibc
$(
if
$(
CONFIG_SOFT_FLOAT
)
,-msoft-float
)
"
\
--cflags
"
$(
if
$(
call qstrip,
$(
CONFIG_TOOLCHAIN_LIBC
))
,-m
$(
call qstrip,
$(
CONFIG_TOOLCHAIN_LIBC
)))
$(
if
$(
CONFIG_SOFT_FLOAT
)
,-msoft-float
)
"
\
--cflags
"
$(
patsubst ./%,-I
$(
TOOLCHAIN_ROOT_DIR
)
/%,
$(
call qstrip,
$(
CONFIG_TOOLCHAIN_INC_PATH
)))
"
\
--cflags
"
$(
patsubst ./%,-I
$(
TOOLCHAIN_ROOT_DIR
)
/%,
$(
call qstrip,
$(
CONFIG_TOOLCHAIN_INC_PATH
)))
"
\
--cflags
"
$(
patsubst ./%,-L
$(
TOOLCHAIN_ROOT_DIR
)
/%,
$(
call qstrip,
$(
CONFIG_TOOLCHAIN_LIB_PATH
)))
"
\
--cflags
"
$(
patsubst ./%,-L
$(
TOOLCHAIN_ROOT_DIR
)
/%,
$(
call qstrip,
$(
CONFIG_TOOLCHAIN_LIB_PATH
)))
"
\
$(
1
))
$(
1
))
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment