Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
c4d7af70
Commit
c4d7af70
authored
15 years ago
by
Ralph Hempel
Browse files
Options
Downloads
Patches
Plain Diff
added BUILD_LOG_DIR variable, make clean will delete the ./logs dir
SVN-Revision: 16148
parent
72e25b07
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
Makefile
+1
-1
1 addition, 1 deletion
Makefile
include/subdir.mk
+2
-2
2 additions, 2 deletions
include/subdir.mk
rules.mk
+1
-0
1 addition, 0 deletions
rules.mk
with
4 additions
and
3 deletions
Makefile
+
1
−
1
View file @
c4d7af70
...
@@ -49,8 +49,8 @@ $(BUILD_DIR)/.prepared: Makefile
...
@@ -49,8 +49,8 @@ $(BUILD_DIR)/.prepared: Makefile
@
touch
$@
@
touch
$@
clean
:
FORCE
clean
:
FORCE
rm
-rf
$(
BUILD_DIR
)
$(
BIN_DIR
)
$(
_SINGLE
)$(
SUBMAKE
)
target/linux/clean
$(
_SINGLE
)$(
SUBMAKE
)
target/linux/clean
rm
-rf
$(
BUILD_DIR
)
$(
BIN_DIR
)
$(
BUILD_LOG_DIR
)
dirclean
:
clean
dirclean
:
clean
rm
-rf
$(
STAGING_DIR
)
$(
STAGING_DIR_HOST
)
$(
STAGING_DIR_TOOLCHAIN
)
$(
TOOLCHAIN_DIR
)
$(
BUILD_DIR_HOST
)
$(
BUILD_DIR_TOOLCHAIN
)
rm
-rf
$(
STAGING_DIR
)
$(
STAGING_DIR_HOST
)
$(
STAGING_DIR_TOOLCHAIN
)
$(
TOOLCHAIN_DIR
)
$(
BUILD_DIR_HOST
)
$(
BUILD_DIR_TOOLCHAIN
)
...
...
This diff is collapsed.
Click to expand it.
include/subdir.mk
+
2
−
2
View file @
c4d7af70
...
@@ -34,8 +34,8 @@ define subdir
...
@@ -34,8 +34,8 @@ define subdir
$(
if
$(
call diralias,
$(
bd
))
,
$(
call warn_eval,
$(
1
)
/
$(
bd
)
,l,T,
$(
1
)
/
$(
call diralias,
$(
bd
))
/
$(
btype
)
/
$(
target
)
:
$(
1
)
/
$(
bd
)
/
$(
btype
)
/
$(
target
)))
$(
if
$(
call diralias,
$(
bd
))
,
$(
call warn_eval,
$(
1
)
/
$(
bd
)
,l,T,
$(
1
)
/
$(
call diralias,
$(
bd
))
/
$(
btype
)
/
$(
target
)
:
$(
1
)
/
$(
bd
)
/
$(
btype
)
/
$(
target
)))
)
)
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target)
:
$(if $(QUILT)
,,
$($(1)/$(bd)/$(target)) $(call $(1)//$(target)
,
$(1)/$(bd))))
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target)
:
$(if $(QUILT)
,,
$($(1)/$(bd)/$(target)) $(call $(1)//$(target)
,
$(1)/$(bd))))
$(
if
$(
BUILD_LOG
)
,@mkdir
-p
$(
TOPDIR
)
/logs
/
$(
1
)
/
$(
bd
))
$(
if
$(
BUILD_LOG
)
,@mkdir
-p
$(
BUILD_LOG_DIR
)
/
$(
1
)
/
$(
bd
))
+
$(
if
$(
BUILD_LOG
)
,set
-o
pipefail
;)
$$(
SUBMAKE
)
-C
$(
1
)
/
$(
bd
)
$(
target
)
$(
if
$(
BUILD_LOG
)
,SILENT
=
2>&1 |
tee
$(
TOPDIR
)
/logs
/
$(
1
)
/
$(
bd
)
/
$(
target
)
.txt
)
$(
if
$(
findstring
$(
bd
)
,
$($(
1
)
/builddirs-ignore-
$(
target
)))
,
||
$(
call MESSAGE, ERROR:
$(
1
)
/
$(
bd
)
failed to build.
))
+
$(
if
$(
BUILD_LOG
)
,set
-o
pipefail
;)
$$(
SUBMAKE
)
-C
$(
1
)
/
$(
bd
)
$(
target
)
$(
if
$(
BUILD_LOG
)
,SILENT
=
2>&1 |
tee
$(
BUILD_LOG_DIR
)
/
$(
1
)
/
$(
bd
)
/
$(
target
)
.txt
)
$(
if
$(
findstring
$(
bd
)
,
$($(
1
)
/builddirs-ignore-
$(
target
)))
,
||
$(
call MESSAGE, ERROR:
$(
1
)
/
$(
bd
)
failed to build.
))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT
:
$(1)/$(bd)/$(target))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT
:
$(1)/$(bd)/$(target))
# legacy targets
# legacy targets
...
...
This diff is collapsed.
Click to expand it.
rules.mk
+
1
−
0
View file @
c4d7af70
...
@@ -64,6 +64,7 @@ STAMP_DIR_HOST=$(BUILD_DIR_HOST)/stamp
...
@@ -64,6 +64,7 @@ STAMP_DIR_HOST=$(BUILD_DIR_HOST)/stamp
TARGET_ROOTFS_DIR
?=
$(
if
$(
call qstrip,
$(
CONFIG_TARGET_ROOTFS_DIR
))
,
$(
call qstrip,
$(
CONFIG_TARGET_ROOTFS_DIR
))
,
$(
BUILD_DIR
))
TARGET_ROOTFS_DIR
?=
$(
if
$(
call qstrip,
$(
CONFIG_TARGET_ROOTFS_DIR
))
,
$(
call qstrip,
$(
CONFIG_TARGET_ROOTFS_DIR
))
,
$(
BUILD_DIR
))
TARGET_DIR
:=
$(
TARGET_ROOTFS_DIR
)
/root-
$(
BOARD
)
TARGET_DIR
:=
$(
TARGET_ROOTFS_DIR
)
/root-
$(
BOARD
)
DEBUG_DIR
:=
$(
BUILD_DIR
)
/debug-
$(
BOARD
)
DEBUG_DIR
:=
$(
BUILD_DIR
)
/debug-
$(
BOARD
)
BUILD_LOG_DIR
:=
$(
TOPDIR
)
/logs
TARGET_PATH
:=
$(
TOOLCHAIN_DIR
)
/usr/bin:
$(
STAGING_DIR_HOST
)
/bin:
$(
PATH
)
TARGET_PATH
:=
$(
TOOLCHAIN_DIR
)
/usr/bin:
$(
STAGING_DIR_HOST
)
/bin:
$(
PATH
)
TARGET_PATH_PKG
:=
$(
STAGING_DIR
)
/host/bin:
$(
TARGET_PATH
)
TARGET_PATH_PKG
:=
$(
STAGING_DIR
)
/host/bin:
$(
TARGET_PATH
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment