Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
d411ddbd
Commit
d411ddbd
authored
18 years ago
by
Imre Kaloz
Browse files
Options
Downloads
Patches
Plain Diff
add NTFS-3G
SVN-Revision: 6279
parent
773ea568
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
package/ntfs-3g/Makefile
+111
-0
111 additions, 0 deletions
package/ntfs-3g/Makefile
package/ntfs-3g/patches/100-no_ldconfig.patch
+12
-0
12 additions, 0 deletions
package/ntfs-3g/patches/100-no_ldconfig.patch
with
123 additions
and
0 deletions
package/ntfs-3g/Makefile
0 → 100644
+
111
−
0
View file @
d411ddbd
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include
$(TOPDIR)/rules.mk
include
$(INCLUDE_DIR)/kernel.mk
PKG_NAME
:=
ntfs-3g
PKG_VERSION
:=
0.20070207-RC1
PKG_RELEASE
:=
1
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tgz
PKG_SOURCE_URL
:=
http://www.ntfs-3g.org/
PKG_MD5SUM
:=
7c8c7a1338a0d36e315b665422e04c46
PKG_CAT
:=
zcat
PKG_BUILD_DIR
:=
$(
KERNEL_BUILD_DIR
)
/
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
PKG_INSTALL_DIR
:=
$(
PKG_BUILD_DIR
)
/ipkg-install
PKG_BUILD_DEPENDS
:=
libfuse
include
$(INCLUDE_DIR)/package.mk
define
Package/ntfs-3g
TITLE
:=
NTFS-3G
DEPENDS
:=
+libfuse +fuse-utils
SECTION
:=
utils
CATEGORY
:=
Utilities
DESCRIPTION
:=
\
Third generation Read/Write NTFS driver
URL
:=
http://www.ntfs-3g.org
endef
define
Build/Configure
(cd
$(PKG_BUILD_DIR);
rm
-f
config.cache;
\
touch
configure.in
;
\
touch
aclocal.m4
;
\
touch
Makefile.in
;
\
touch
include/config.h.in
;
\
touch
configure
;
\
$(TARGET_CONFIGURE_OPTS)
\
PKG_CONFIG_PATH
=
"
$(
STAGING_DIR
)
/usr/lib/pkgconfig"
\
PKG_CONFIG_LIBDIR
=
"
$(
STAGING_DIR
)
/usr/lib/pkgconfig"
\
CPPFLAGS
=
"-I
$(
STAGING_DIR
)
/usr/include"
\
CFLAGS
=
"
$(
TARGET_CFLAGS
)
"
\
LDFLAGS
=
"-L
$(
STAGING_DIR
)
/usr/lib"
\
./configure
\
--target
=
$(
GNU_TARGET_NAME
)
\
--host
=
$(
GNU_TARGET_NAME
)
\
--build
=
$(
GNU_HOST_NAME
)
\
--program-prefix
=
""
\
--program-suffix
=
""
\
--prefix
=
/usr
\
--exec-prefix
=
/usr
\
--bindir
=
/usr/bin
\
--datadir
=
/usr/share
\
--includedir
=
/usr/include
\
--infodir
=
/usr/share/info
\
--libdir
=
/usr/lib
\
--libexecdir
=
/usr/lib
\
--localstatedir
=
/var
\
--mandir
=
/usr/share/man
\
--sbindir
=
/usr/sbin
\
--sysconfdir
=
/etc
\
$(
DISABLE_LARGEFILE
)
\
$(
DISABLE_NLS
)
\
--enable-shared
\
--enable-static
\
--disable-rpath
\
--enable-kernel-module
\
--enable-lib
\
--enable-util
\
--disable-example
\
--disable-auto-modprobe
\
--with-kernel
=
"
$(
LINUX_DIR
)
"
\
--disable-mtab
\
)
;
endef
define
Build/Compile
$(MAKE)
-C
$(PKG_BUILD_DIR)
\
ARCH
=
"
$(
LINUX_KARCH
)
"
\
CROSS_COMPILE
=
"
$(
TARGET_CROSS
)
"
\
DESTDIR
=
"
$(
PKG_INSTALL_DIR
)
"
\
all
install
endef
define
Build/InstallDev
mkdir
-p
$(STAGING_DIR)/usr/include
$(CP)
$(PKG_INSTALL_DIR)/usr/include/ntfs-3g
$(STAGING_DIR)/usr/include/
mkdir
-p
$(STAGING_DIR)/usr/lib
$(CP)
$(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.{a,so*}
$(STAGING_DIR)/usr/lib/
endef
define
Build/UninstallDev
rm
-rf
$(STAGING_DIR)/usr/include/ntfs-3g
\
$(STAGING_DIR)/usr/lib/libntfs-3g.{a,so*}
endef
define
Package/ntfs-3g/install
$(INSTALL_DIR)
$(1)/usr/bin
$(CP)
$(PKG_INSTALL_DIR)/usr/bin/ntfs-3g
$(1)/usr/bin/
$(INSTALL_DIR)
$(1)/usr/lib
$(CP)
$(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.*
$(1)/usr/lib/
endef
$(
eval
$(
call BuildPackage,ntfs-3g
))
This diff is collapsed.
Click to expand it.
package/ntfs-3g/patches/100-no_ldconfig.patch
0 → 100644
+
12
−
0
View file @
d411ddbd
diff -Nur ntfs-3g-0.20070207-RC1/src/Makefile.in ntfs-3g-0.20070207-RC1-owrt/src/Makefile.in
--- ntfs-3g-0.20070207-RC1/src/Makefile.in 2007-02-06 22:43:10.000000000 +0100
+++ ntfs-3g-0.20070207-RC1-owrt/src/Makefile.in 2007-02-08 12:54:27.000000000 +0100
@@ -582,7 +582,7 @@
install-exec-hook:
$(INSTALL) -d $(DESTDIR)/sbin
$(LN_S) -f $(bindir)/ntfs-3g $(DESTDIR)/sbin/mount.ntfs-3g
- $(LDCONFIG)
+# $(LDCONFIG)
install-data-hook:
$(INSTALL) -d $(DESTDIR)$(man8dir)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment