Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
da774085
Commit
da774085
authored
16 years ago
by
Gabor Juhos
Browse files
Options
Downloads
Patches
Plain Diff
i2c-gpio-custom: minor bugfix
SVN-Revision: 12297
parent
904effc1
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
package/i2c-gpio-custom/Makefile
+1
-2
1 addition, 2 deletions
package/i2c-gpio-custom/Makefile
package/i2c-gpio-custom/src/i2c-gpio-custom.c
+10
-9
10 additions, 9 deletions
package/i2c-gpio-custom/src/i2c-gpio-custom.c
with
11 additions
and
11 deletions
package/i2c-gpio-custom/Makefile
+
1
−
2
View file @
da774085
...
...
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include
$(INCLUDE_DIR)/kernel.mk
PKG_NAME
:=
i2c-gpio-custom
PKG_RELEASE
:=
1
PKG_RELEASE
:=
2
include
$(INCLUDE_DIR)/package.mk
...
...
@@ -18,7 +18,6 @@ define KernelPackage/i2c-gpio-custom
TITLE
:=
Custom GPIO-based I2C device
DEPENDS
:=
@GPIO_SUPPORT kmod-i2c-core +kmod-i2c-gpio
FILES
:=
$(
PKG_BUILD_DIR
)
/i2c-gpio-custom.
$(
LINUX_KMOD_SUFFIX
)
AUTOLOAD
:=
$(
call AutoLoad,58,i2c-gpio-custom
)
KCONFIG
:=
endef
...
...
This diff is collapsed.
Click to expand it.
package/i2c-gpio-custom/src/i2c-gpio-custom.c
+
10
−
9
View file @
da774085
/*
* Custom GPIO-based I2C driver
*
* Copyright (C) 2007 Gabor Juhos <juhosg
at
openwrt.org>
* Copyright (C) 2007
-2008
Gabor Juhos <juhosg
@
openwrt.org>
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License version 2 as
...
...
@@ -51,7 +51,7 @@
#define DRV_NAME "i2c-gpio-custom"
#define DRV_DESC "Custom GPIO-based I2C driver"
#define DRV_VERSION "0.1.
0
"
#define DRV_VERSION "0.1.
1
"
#define PFX DRV_NAME ": "
...
...
@@ -96,7 +96,7 @@ static void i2c_gpio_custom_cleanup(void)
for
(
i
=
0
;
i
<
nr_devices
;
i
++
)
if
(
devices
[
i
])
platform_device_
unregister
(
devices
[
i
]);
platform_device_
put
(
devices
[
i
]);
}
static
int
__init
i2c_gpio_custom_add_one
(
unsigned
int
id
,
unsigned
int
*
params
)
...
...
@@ -120,8 +120,6 @@ static int __init i2c_gpio_custom_add_one(unsigned int id, unsigned int *params)
goto
err
;
}
devices
[
nr_devices
++
]
=
pdev
;
pdata
.
sda_pin
=
params
[
BUS_PARAM_SDA
];
pdata
.
scl_pin
=
params
[
BUS_PARAM_SCL
];
pdata
.
udelay
=
params
[
BUS_PARAM_UDELAY
];
...
...
@@ -132,14 +130,17 @@ static int __init i2c_gpio_custom_add_one(unsigned int id, unsigned int *params)
err
=
platform_device_add_data
(
pdev
,
&
pdata
,
sizeof
(
pdata
));
if
(
err
)
goto
err
;
goto
err
_put
;
err
=
platform_device_
register
(
pdev
);
err
=
platform_device_
add
(
pdev
);
if
(
err
)
goto
err
;
goto
err
_put
;
devices
[
nr_devices
++
]
=
pdev
;
return
0
;
err_put:
platform_device_put
(
pdev
);
err:
return
err
;
}
...
...
@@ -192,6 +193,6 @@ subsys_initcall(i2c_gpio_custom_probe);
#endif
/* MODULE*/
MODULE_LICENSE
(
"GPL v2"
);
MODULE_AUTHOR
(
"Gabor Juhos <juhosg
at
openwrt.org >"
);
MODULE_AUTHOR
(
"Gabor Juhos <juhosg
@
openwrt.org >"
);
MODULE_DESCRIPTION
(
DRV_DESC
);
MODULE_VERSION
(
DRV_VERSION
);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment