Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
e8d1e4e7
Commit
e8d1e4e7
authored
18 years ago
by
Mike Baker
Browse files
Options
Downloads
Patches
Plain Diff
minor makefile tweaks
SVN-Revision: 4393
parent
1d7ff678
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
openwrt/Makefile
+9
-9
9 additions, 9 deletions
openwrt/Makefile
openwrt/include/package.mk
+29
-28
29 additions, 28 deletions
openwrt/include/package.mk
openwrt/rules.mk
+1
-0
1 addition, 0 deletions
openwrt/rules.mk
with
39 additions
and
37 deletions
openwrt/Makefile
+
9
−
9
View file @
e8d1e4e7
...
@@ -14,18 +14,17 @@ RELEASE:=Kamikaze
...
@@ -14,18 +14,17 @@ RELEASE:=Kamikaze
# Just run 'make menuconfig', configure stuff, then run 'make'.
# Just run 'make menuconfig', configure stuff, then run 'make'.
# You shouldn't need to mess with anything beyond this point...
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
#--------------------------------------------------------------
TOPDIR
=
${
shell
pwd
}
export
TOPDIR
=
${
shell
pwd
}
export
TOPDIR
include
$(TOPDIR)/include/verbose.mk
include
$(TOPDIR)/include/verbose.mk
OPENWRTVERSION
:=
$(
RELEASE
)
OPENWRTVERSION
:=
$(
RELEASE
)
ifneq
($(VERSION),)
ifneq
($(VERSION),)
OPENWRTVERSION
:=
$(
VERSION
)
(
$(
OPENWRTVERSION
)
)
OPENWRTVERSION
:=
$(
VERSION
)
(
$(
OPENWRTVERSION
)
)
else
else
REV
:=
$(
shell
LANG
=
C svn info |
awk
'/^Revision:/ { print$$2
}
'
)
REV
:=
$(
shell
LANG
=
C svn info |
awk
'/^Revision:/ { print$$2
}
'
)
ifneq
($(REV),)
ifneq
($(REV),)
OPENWRTVERSION
:=
$(
OPENWRTVERSION
)
/r
$(
REV
)
OPENWRTVERSION
:=
$(
OPENWRTVERSION
)
/r
$(
REV
)
endif
endif
endif
endif
export
OPENWRTVERSION
export
OPENWRTVERSION
...
@@ -40,7 +39,7 @@ endif
...
@@ -40,7 +39,7 @@ endif
@
echo
Collecting package info...
@
echo
Collecting package info...
@
-for
dir
in
package/
*
/
;
do
\
@
-for
dir
in
package/
*
/
;
do
\
echo
Source-Makefile:
$${
dir
}
Makefile
;
\
echo
Source-Makefile:
$${
dir
}
Makefile
;
\
$(
NO_TRACE_MAKE
)
--no-print-dir
DUMP
=
1
-C
$$
dir
2>&-
||
true
;
\
$(
NO_TRACE_MAKE
)
--no-print-dir
DUMP
=
1
-C
$$
dir
2>&-
||
echo
"ERROR: please fix package/
$${
dir
}
/Makefile"
>
&2
;
\
done
>
$@
done
>
$@
.config.in
:
.pkginfo
.config.in
:
.pkginfo
...
@@ -129,5 +128,6 @@ distclean: dirclean config-clean
...
@@ -129,5 +128,6 @@ distclean: dirclean config-clean
.SILENT
:
clean dirclean distclean config-clean download world
.SILENT
:
clean dirclean distclean config-clean download world
FORCE
:
;
.PHONY
:
FORCE
.PHONY
:
FORCE
FORCE
:
%
:
;
This diff is collapsed.
Click to expand it.
openwrt/include/package.mk
+
29
−
28
View file @
e8d1e4e7
...
@@ -40,19 +40,19 @@ define Build/DefaultTargets
...
@@ -40,19 +40,19 @@ define Build/DefaultTargets
$(
call Build/Compile
)
$(
call Build/Compile
)
touch
$$
@
touch
$$
@
$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
:
$(PKG_BUILD_DIR)/.built
ifdef
Build/InstallDev
$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
:
$(PKG_BUILD_DIR)/.built
mkdir
-p
$(
STAGING_DIR
)
/stampfiles
mkdir
-p
$(
STAGING_DIR
)
/stampfiles
$(
call Build/InstallDev
)
$(
call Build/InstallDev
)
touch
$$
@
touch
$$
@
ifdef
Build/InstallDev
compile-targets
:
$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
compile-targets
:
$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
endif
endif
package-clean
:
FORCE
package-clean
:
FORCE
$(
call Build/Clean
)
$(
call Build/Clean
)
$(
call Build/UninstallDev
)
$(
call Build/UninstallDev
)
rm
-f
$(
STAGING_DIR
)
/stampfiles/.
$(
PKG_NAME
)
-installed
-
rm
-f
$(
STAGING_DIR
)
/stampfiles/.
$(
PKG_NAME
)
-installed
package-rebuild
:
FORCE
package-rebuild
:
FORCE
@
-rm
-f
$(
PKG_BUILD_DIR
)
/.built
@
-rm
-f
$(
PKG_BUILD_DIR
)
/.built
...
@@ -89,9 +89,9 @@ define Package/Default
...
@@ -89,9 +89,9 @@ define Package/Default
endef
endef
define
BuildIPKGVariable
define
BuildIPKGVariable
pkg_
$(
subst
.,_,
$(
subst -,_,
$(
1
)))
_$(2)
=
$$(
Package/
$(
1
)
/
$(
2
))
pkg_
$(
subst
.,_,
$(
subst -,_,
$(
1
)))
_$(2)
=
$$(
Package/
$(
1
)
/
$(
2
))
export
pkg_
$(
subst
.,_,
$(
subst -,_,
$(
1
))
_
$(
2
))
export
pkg_
$(
subst
.,_,
$(
subst -,_,
$(
1
))
_
$(
2
))
$(1)_COMMANDS
+=
if
[
-n
"
$$$$$$$$
pkg_
$(
subst .,_,
$(
subst -,_,
$(
1
)))
_
$(
2
)
"
]
;
then
echo
"
$$$$$$$$
pkg_
$(
subst .,_,
$(
subst -,_,
$(
1
)))
_
$(
2
)
"
>
$(
2
);
fi
;
$(1)_COMMANDS
+=
if
[
-n
"
$$$$$$$$
pkg_
$(
subst .,_,
$(
subst -,_,
$(
1
)))
_
$(
2
)
"
]
;
then
echo
"
$$$$$$$$
pkg_
$(
subst .,_,
$(
subst -,_,
$(
1
)))
_
$(
2
)
"
>
$(
2
);
fi
;
endef
endef
define
BuildPackage
define
BuildPackage
...
@@ -132,29 +132,30 @@ define BuildPackage
...
@@ -132,29 +132,30 @@ define BuildPackage
IDEPEND_$(1)
:=
$$(
strip
$$(
DEPENDS
))
IDEPEND_$(1)
:=
$$(
strip
$$(
DEPENDS
))
DUMPINFO
+=
\
ifneq
($(DUMP),)
DUMPINFO
+=
\
echo
"Package:
$(
1
)
"
;
echo
"Package:
$(
1
)
"
;
ifneq
($(MENU),)
ifneq
($(MENU),)
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
"Menu:
$(
MENU
)
"
;
echo
"Menu:
$(
MENU
)
"
;
endif
endif
ifneq
($(SUBMENU),)
ifneq
($(SUBMENU),)
DUMPINFO
+=
\
echo
"Submenu:
$(
SUBMENU
)
"
;
ifneq
($(SUBMENUDEP),)
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
"Submenu:
$(
SUBMENU
)
"
;
ifneq
($(SUBMENUDEP),)
DUMPINFO
+=
\
echo
"Submenu-Depends:
$(
SUBMENUDEP
)
"
;
echo
"Submenu-Depends:
$(
SUBMENUDEP
)
"
;
endif
endif
endif
endif
ifneq
($(DEFAULT),)
ifneq
($(DEFAULT),)
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
"Default:
$(
DEFAULT
)
"
;
echo
"Default:
$(
DEFAULT
)
"
;
endif
endif
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
"Version:
$(
VERSION
)
"
;
\
echo
"Version:
$(
VERSION
)
"
;
\
echo
"Depends:
$$(
IDEPEND_
$(
1
))
"
;
\
echo
"Depends:
$$(
IDEPEND_
$(
1
))
"
;
\
echo
"Build-Depends:
$(
PKG_BUILDDEP
)
"
;
\
echo
"Build-Depends:
$(
PKG_BUILDDEP
)
"
;
\
...
@@ -162,19 +163,20 @@ define BuildPackage
...
@@ -162,19 +163,20 @@ define BuildPackage
echo
"Title:
$(
TITLE
)
"
;
\
echo
"Title:
$(
TITLE
)
"
;
\
echo
"Description:
$(
DESCRIPTION
)
"
|
sed
-e
's,\\,\n,g'
;
echo
"Description:
$(
DESCRIPTION
)
"
|
sed
-e
's,\\,\n,g'
;
ifneq
($(URL),)
ifneq
($(URL),)
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
;
\
echo
;
\
echo
"
$(
URL
)
"
;
echo
"
$(
URL
)
"
;
endif
endif
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
"@@"
;
echo
"@@"
;
ifneq
($(CONFIG),)
ifneq
($(CONFIG),)
DUMPINFO
+=
\
DUMPINFO
+=
\
echo
"Config:
$(
CONFIG
)
"
|
sed
-e
's,\\,\n,g'
;
\
echo
"Config:
$(
CONFIG
)
"
|
sed
-e
's,\\,\n,g'
;
\
echo
"@@"
;
echo
"@@"
;
endif
endif
endif
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,conffiles
))
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,conffiles
))
...
@@ -182,7 +184,7 @@ define BuildPackage
...
@@ -182,7 +184,7 @@ define BuildPackage
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,postinst
))
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,postinst
))
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,prerm
))
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,prerm
))
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,postrm
))
$(
eval
$(
call BuildIPKGVariable,
$(
1
)
,postrm
))
$$(IDIR_$(1))/CONTROL/control
:
Makefile $(PKG_BUILD_DIR)/.prepared
$(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
$$(IDIR_$(1))/CONTROL/control
:
$(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
mkdir
-p
$$(
IDIR_
$(
1
))
/CONTROL
mkdir
-p
$$(
IDIR_
$(
1
))
/CONTROL
echo
"Package:
$(
1
)
"
>
$$(
IDIR_
$(
1
))
/CONTROL/control
echo
"Package:
$(
1
)
"
>
$$(
IDIR_
$(
1
))
/CONTROL/control
echo
"Version:
$(
VERSION
)
"
>>
$$(
IDIR_
$(
1
))
/CONTROL/control
echo
"Version:
$(
VERSION
)
"
>>
$$(
IDIR_
$(
1
))
/CONTROL/control
...
@@ -204,7 +206,7 @@ define BuildPackage
...
@@ -204,7 +206,7 @@ define BuildPackage
$($(
1
)
_COMMANDS
)
\
$($(
1
)
_COMMANDS
)
\
)
)
$$(IPKG_$(1))
:
$$(IDIR_$(1))/CONTROL/control
$(PKG_BUILD_DIR)/.built
$$(IPKG_$(1))
:
$(PKG_BUILD_DIR)/.built
$$(IDIR_$(1))/CONTROL/control
$(
call Package/
$(
1
)
/install,
$$(
IDIR_
$(
1
)))
$(
call Package/
$(
1
)
/install,
$$(
IDIR_
$(
1
)))
mkdir
-p
$(
PACKAGE_DIR
)
mkdir
-p
$(
PACKAGE_DIR
)
-
find
$$(
IDIR_
$(
1
))
-name
CVS | xargs
rm
-rf
-
find
$$(
IDIR_
$(
1
))
-name
CVS | xargs
rm
-rf
...
@@ -227,7 +229,6 @@ define BuildPackage
...
@@ -227,7 +229,6 @@ define BuildPackage
@
touch
$$
@
@
touch
$$
@
$
$(
eval
$$(
call Build/DefaultTargets,
$(
1
)))
$
$(
eval
$$(
call Build/DefaultTargets,
$(
1
)))
endef
endef
ifneq
($(strip $(PKG_CAT)),)
ifneq
($(strip $(PKG_CAT)),)
...
...
This diff is collapsed.
Click to expand it.
openwrt/rules.mk
+
1
−
0
View file @
e8d1e4e7
...
@@ -117,3 +117,4 @@ endif
...
@@ -117,3 +117,4 @@ endif
all
:
all
:
FORCE
:
;
FORCE
:
;
.PHONY
:
FORCE
.PHONY
:
FORCE
%
:
;
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment