Skip to content
Snippets Groups Projects
Commit f2961c9c authored by Rui Salvaterra's avatar Rui Salvaterra Committed by Daniel Golle
Browse files

kernel: bump 5.10 to 5.10.53


No deleted or manually refreshed patches.

Signed-off-by: default avatarRui Salvaterra <rsalvaterra@gmail.com>
parent a57d7c29
Branches
No related tags found
No related merge requests found
......@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-5.4 = .134
LINUX_VERSION-5.10 = .52
LINUX_VERSION-5.10 = .53
LINUX_KERNEL_HASH-5.4.134 = c9fb861642161c256e10c97c35ccce18831e688d87ead53c18e3226778e05841
LINUX_KERNEL_HASH-5.10.52 = 769e57a0fa218589fa2f8460b8682eb784a72718c7a3d95295f382a77902ae79
LINUX_KERNEL_HASH-5.10.53 = f0058d902933986dbaf03b2a0304d2babe5fe1c8e3f41f156ffd3c3f210106dc
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
......
......@@ -214,7 +214,7 @@
#include <linux/uaccess.h>
#include <linux/ipv6.h>
#include <linux/icmpv6.h>
@@ -909,10 +910,10 @@ static void tcp_v6_send_response(const s
@@ -924,10 +925,10 @@ static void tcp_v6_send_response(const s
topt = (__be32 *)(t1 + 1);
if (tsecr) {
......
......@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -7027,7 +7027,7 @@ static void __ref alloc_node_mem_map(str
@@ -7053,7 +7053,7 @@ static void __ref alloc_node_mem_map(str
if (pgdat == NODE_DATA(0)) {
mem_map = NODE_DATA(0)->node_mem_map;
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
......
......@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
@@ -734,11 +734,11 @@ KBUILD_CFLAGS += $(call cc-disable-warni
@@ -735,11 +735,11 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
ifdef CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE
......
......@@ -17,7 +17,7 @@ Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
--- a/drivers/net/dsa/mv88e6xxx/chip.c
+++ b/drivers/net/dsa/mv88e6xxx/chip.c
@@ -5401,6 +5401,7 @@ static int mv88e6xxx_register_switch(str
@@ -5409,6 +5409,7 @@ static int mv88e6xxx_register_switch(str
ds->ops = &mv88e6xxx_switch_ops;
ds->ageing_time_min = chip->info->age_time_coeff;
ds->ageing_time_max = chip->info->age_time_coeff * U8_MAX;
......
......@@ -22,9 +22,9 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
const __be32 *_id = of_get_property(np, "reg", NULL);
phy_interface_t phy_mode;
struct phylink *phylink;
@@ -3006,6 +3007,9 @@ static int mtk_add_mac(struct mtk_eth *e
eth->netdev[id]->max_mtu = MTK_MAX_RX_LENGTH - MTK_RX_ETH_HLEN;
@@ -3008,6 +3009,9 @@ static int mtk_add_mac(struct mtk_eth *e
of_platform_device_create(np, NULL, NULL);
+ if (name)
+ strlcpy(eth->netdev[id]->name, name, IFNAMSIZ);
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment