Skip to content
Snippets Groups Projects
Commit 8cac8572 authored by Kevin Darbyshire-Bryant's avatar Kevin Darbyshire-Bryant
Browse files

iproute2: q_cake: Add printing of no-split-gso option


When the GSO splitting was turned into dual split-gso/no-split-gso options,
the printing of the latter was left out. Add that, so output is consistent
with the options passed

Signed-off-by: default avatarKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
parent b3d441c5
No related branches found
No related tags found
No related merge requests found
......@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=4.18.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
......
......@@ -854,7 +854,7 @@
TCMODULES += e_bpf.o
--- /dev/null
+++ b/tc/q_cake.c
@@ -0,0 +1,799 @@
@@ -0,0 +1,801 @@
+// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
+
+/*
......@@ -1381,6 +1381,8 @@
+
+ if (split_gso)
+ print_string(PRINT_FP, NULL, "split-gso ", NULL);
+ else
+ print_string(PRINT_FP, NULL, "no-split-gso ", NULL);
+ print_bool(PRINT_JSON, "split_gso", NULL, split_gso);
+
+ if (interval)
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment